diff options
author | Li Jin <dragon-fly@qq.com> | 2021-01-10 19:13:29 +0800 |
---|---|---|
committer | Li Jin <dragon-fly@qq.com> | 2021-01-10 19:13:29 +0800 |
commit | 843d43f57a52948cf33d126582a01085ffc33421 (patch) | |
tree | 81bb0c43d044c7523f71497feb96be09f90ab312 /CMakeLists.txt | |
parent | c450939951ccb552261f4d74b6e791083becb927 (diff) | |
download | yuescript-843d43f57a52948cf33d126582a01085ffc33421.tar.gz yuescript-843d43f57a52948cf33d126582a01085ffc33421.tar.bz2 yuescript-843d43f57a52948cf33d126582a01085ffc33421.zip |
fix build issues.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 13 |
1 files changed, 6 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 91ff57f..442f226 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -28,14 +28,13 @@ enable_language( CXX ) | |||
28 | include_directories( src ${LUA_INCLUDE_DIR} ) | 28 | include_directories( src ${LUA_INCLUDE_DIR} ) |
29 | add_definitions( -std=c++17 -O3 -fPIC ) | 29 | add_definitions( -std=c++17 -O3 -fPIC ) |
30 | 30 | ||
31 | add_library( moonp MODULE src/MoonP/ast.cpp src/MoonP/parser.cpp src/MoonP/moon_parser.cpp src/MoonP/moon_compiler.cpp src/MoonP/moonplus.cpp) | 31 | add_library( libmoonp MODULE src/MoonP/ast.cpp src/MoonP/parser.cpp src/MoonP/moon_parser.cpp src/MoonP/moon_compiler.cpp src/MoonP/moonplus.cpp) |
32 | set_target_properties( moonp PROPERTIES PREFIX "") | 32 | set_target_properties( libmoonp PROPERTIES PREFIX "" ) |
33 | target_link_libraries( moonp ${LUA_LIBRARIES} ) | 33 | set_target_properties( libmoonp PROPERTIES OUTPUT_NAME "moonp" ) |
34 | target_link_libraries( libmoonp ${LUA_LIBRARIES} ) | ||
34 | 35 | ||
35 | add_custom_command(TARGET moonp | 36 | add_executable( moonp src/MoonP/ast.cpp src/MoonP/moon_compiler.cpp src/MoonP/moon_parser.cpp src/MoonP/moonplus.cpp src/MoonP/parser.cpp src/moonp.cpp ) |
36 | POST_BUILD | 37 | target_link_libraries( moonp ${LUA_LIBRARIES} ) |
37 | COMMAND make release | ||
38 | WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}) | ||
39 | 38 | ||
40 | install(CODE "") | 39 | install(CODE "") |
41 | 40 | ||