diff options
author | Li Jin <dragon-fly@qq.com> | 2023-06-29 10:58:56 +0800 |
---|---|---|
committer | Li Jin <dragon-fly@qq.com> | 2023-06-29 10:58:56 +0800 |
commit | c98c6053635ddfca7aab15b268b0f2c1fcc0c6ef (patch) | |
tree | dcacf24e010346eb03e834d8081eb81e26f5c7ff /CMakeLists.txt | |
parent | 51faef5288a64a84b8f8e5cea8631c7518b94411 (diff) | |
download | yuescript-c98c6053635ddfca7aab15b268b0f2c1fcc0c6ef.tar.gz yuescript-c98c6053635ddfca7aab15b268b0f2c1fcc0c6ef.tar.bz2 yuescript-c98c6053635ddfca7aab15b268b0f2c1fcc0c6ef.zip |
fix issue #139.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 6 |
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 3ecec9a..8d5908f 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -61,6 +61,7 @@ endif () | |||
61 | add_library(libyue MODULE | 61 | add_library(libyue MODULE |
62 | src/yuescript/ast.cpp | 62 | src/yuescript/ast.cpp |
63 | src/yuescript/parser.cpp | 63 | src/yuescript/parser.cpp |
64 | src/yuescript/yue_ast.cpp | ||
64 | src/yuescript/yue_parser.cpp | 65 | src/yuescript/yue_parser.cpp |
65 | src/yuescript/yue_compiler.cpp | 66 | src/yuescript/yue_compiler.cpp |
66 | src/yuescript/yuescript.cpp | 67 | src/yuescript/yuescript.cpp |
@@ -71,10 +72,11 @@ target_link_libraries(libyue ${LUA_LIBRARIES}) | |||
71 | 72 | ||
72 | add_executable(yue | 73 | add_executable(yue |
73 | src/yuescript/ast.cpp | 74 | src/yuescript/ast.cpp |
74 | src/yuescript/yue_compiler.cpp | 75 | src/yuescript/parser.cpp |
76 | src/yuescript/yue_ast.cpp | ||
75 | src/yuescript/yue_parser.cpp | 77 | src/yuescript/yue_parser.cpp |
78 | src/yuescript/yue_compiler.cpp | ||
76 | src/yuescript/yuescript.cpp | 79 | src/yuescript/yuescript.cpp |
77 | src/yuescript/parser.cpp | ||
78 | src/yue.cpp | 80 | src/yue.cpp |
79 | ) | 81 | ) |
80 | 82 | ||