diff options
author | Li Jin <dragon-fly@qq.com> | 2021-01-11 11:21:35 +0800 |
---|---|---|
committer | Li Jin <dragon-fly@qq.com> | 2021-01-11 11:21:35 +0800 |
commit | 7c2c408e1c0108269d2ad7cc7e1394aeaeeed87f (patch) | |
tree | 3bd8f196d0cce7c35c7621a8f310879c6f5a71d8 /CMakeLists.txt | |
parent | 4937e32a628b6950f698f147a121bac6376dd3ba (diff) | |
download | yuescript-7c2c408e1c0108269d2ad7cc7e1394aeaeeed87f.tar.gz yuescript-7c2c408e1c0108269d2ad7cc7e1394aeaeeed87f.tar.bz2 yuescript-7c2c408e1c0108269d2ad7cc7e1394aeaeeed87f.zip |
add missing flag for gcc.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 442f226..7374e1c 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -26,7 +26,7 @@ MESSAGE(STATUS "Lua library: ${LUA_LIBRARIES}") | |||
26 | 26 | ||
27 | enable_language( CXX ) | 27 | enable_language( CXX ) |
28 | include_directories( src ${LUA_INCLUDE_DIR} ) | 28 | include_directories( src ${LUA_INCLUDE_DIR} ) |
29 | add_definitions( -std=c++17 -O3 -fPIC ) | 29 | add_definitions( -std=c++17 -O3 -fPIC -lstdc++fs -ldl -Wno-unused-command-line-argument ) |
30 | 30 | ||
31 | add_library( libmoonp MODULE src/MoonP/ast.cpp src/MoonP/parser.cpp src/MoonP/moon_parser.cpp src/MoonP/moon_compiler.cpp src/MoonP/moonplus.cpp) | 31 | add_library( libmoonp MODULE src/MoonP/ast.cpp src/MoonP/parser.cpp src/MoonP/moon_parser.cpp src/MoonP/moon_compiler.cpp src/MoonP/moonplus.cpp) |
32 | set_target_properties( libmoonp PROPERTIES PREFIX "" ) | 32 | set_target_properties( libmoonp PROPERTIES PREFIX "" ) |