diff options
author | Li Jin <dragon-fly@qq.com> | 2020-03-25 09:59:59 +0800 |
---|---|---|
committer | Li Jin <dragon-fly@qq.com> | 2020-03-25 09:59:59 +0800 |
commit | de47e975ff05a7fa3b9d066db9d500b090990f11 (patch) | |
tree | b0454baadb8d65c369aa6b9e78f3dc6240a26974 /CMakeLists.txt | |
parent | f2f322c801a4a1c7fc736dcf7461420eda47e49b (diff) | |
download | yuescript-de47e975ff05a7fa3b9d066db9d500b090990f11.tar.gz yuescript-de47e975ff05a7fa3b9d066db9d500b090990f11.tar.bz2 yuescript-de47e975ff05a7fa3b9d066db9d500b090990f11.zip |
fix luarocks build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 2b61d8f..89dc716 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -29,7 +29,7 @@ find_package( Lua REQUIRED ) | |||
29 | include_directories( src ${LUA_INCLUDE_DIR} ) | 29 | include_directories( src ${LUA_INCLUDE_DIR} ) |
30 | add_definitions( -std=c++17 -O3 -DLUA_COMPAT_5_2 -DLUA_COMPAT_5_1 ) | 30 | add_definitions( -std=c++17 -O3 -DLUA_COMPAT_5_2 -DLUA_COMPAT_5_1 ) |
31 | 31 | ||
32 | add_library( moonp MODULE src/MoonP/ast.cpp src/MoonP/parser.cpp src/MoonP/moon_parser.cpp src/MoonP/moon_compiler.cpp src/MoonP/moonplus.cpp src/moonp.cpp) | 32 | add_library( moonp MODULE src/MoonP/ast.cpp src/MoonP/parser.cpp src/MoonP/moon_parser.cpp src/MoonP/moon_compiler.cpp src/MoonP/moonplus.cpp) |
33 | set_target_properties( moonp PROPERTIES PREFIX "") | 33 | set_target_properties( moonp PROPERTIES PREFIX "") |
34 | target_link_libraries( moonp ${LUA_LIBRARIES} ) | 34 | target_link_libraries( moonp ${LUA_LIBRARIES} ) |
35 | 35 | ||