aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLi Jin <dragon-fly@qq.com>2023-05-15 11:34:26 +0800
committerLi Jin <dragon-fly@qq.com>2023-05-15 11:34:57 +0800
commita8c4737494818e6591cac2191bf3a49cbe990173 (patch)
tree9ff8fb4cef4378e5d1872951d60b4143eaac73bc /CMakeLists.txt
parentbc28651b0a3e44606001c1f58d6b0746fd698950 (diff)
downloadyuescript-a8c4737494818e6591cac2191bf3a49cbe990173.tar.gz
yuescript-a8c4737494818e6591cac2191bf3a49cbe990173.tar.bz2
yuescript-a8c4737494818e6591cac2191bf3a49cbe990173.zip
fix issue #132.v0.16.3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc2c234..3ecec9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,6 +54,10 @@ enable_language(CXX)
54include_directories(src src/3rdParty ${LUA_INCLUDE_DIR}) 54include_directories(src src/3rdParty ${LUA_INCLUDE_DIR})
55add_definitions(-std=c++17 -O3 -fPIC) 55add_definitions(-std=c++17 -O3 -fPIC)
56 56
57if (APPLE)
58 add_definitions(-Wno-deprecated-declarations)
59endif ()
60
57add_library(libyue MODULE 61add_library(libyue MODULE
58 src/yuescript/ast.cpp 62 src/yuescript/ast.cpp
59 src/yuescript/parser.cpp 63 src/yuescript/parser.cpp