summaryrefslogtreecommitdiff
path: root/contrib/minizip/configure.ac
diff options
context:
space:
mode:
authorJonathan Nieder <jrnieder@gmail.com>2012-01-21 15:55:54 -0600
committerMark Adler <madler@alumni.caltech.edu>2012-01-21 17:15:48 -0800
commit32d8a5379eb91c7fd55304b567a07ad0e2524398 (patch)
tree03b38c1041f55373781a82b01105b43a0370bea9 /contrib/minizip/configure.ac
parentf0cff24214d437ef28d0eb92f9bc45a36cf25530 (diff)
downloadzlib-32d8a5379eb91c7fd55304b567a07ad0e2524398.tar.gz
zlib-32d8a5379eb91c7fd55304b567a07ad0e2524398.tar.bz2
zlib-32d8a5379eb91c7fd55304b567a07ad0e2524398.zip
Add an --enable-demos option to contrib/minizip/configure.
This makes build-testing and installing the minizip/miniunzip programs as simple as "autoreconf -if && ./configure --enable-demos && make && make install". Without --enable-demos, the makefile will only build and install the library, as before. Helped by Mike Frysinger. minizip/miniunzip were not intended to be general-purpose installed utilities, but they can be useful from time to time as a lightweight substitute for zip/unzip. You can also use them to quickly test that the library installation procedure worked.
Diffstat (limited to 'contrib/minizip/configure.ac')
-rw-r--r--contrib/minizip/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/contrib/minizip/configure.ac b/contrib/minizip/configure.ac
index 4799cdc..53adbb8 100644
--- a/contrib/minizip/configure.ac
+++ b/contrib/minizip/configure.ac
@@ -6,6 +6,16 @@ AC_CONFIG_SRCDIR([minizip.c])
6AM_INIT_AUTOMAKE([foreign]) 6AM_INIT_AUTOMAKE([foreign])
7LT_INIT 7LT_INIT
8 8
9AC_MSG_CHECKING([whether to build example programs])
10AC_ARG_ENABLE([demos], AC_HELP_STRING([--enable-demos], [build example programs]))
11AM_CONDITIONAL([COND_DEMOS], [test "$enable_demos" = yes])
12if test "$enable_demos" = yes
13then
14 AC_MSG_RESULT([yes])
15else
16 AC_MSG_RESULT([no])
17fi
18
9AC_SUBST([HAVE_UNISTD_H], [0]) 19AC_SUBST([HAVE_UNISTD_H], [0])
10AC_CHECK_HEADER([unistd.h], [HAVE_UNISTD_H=1], []) 20AC_CHECK_HEADER([unistd.h], [HAVE_UNISTD_H=1], [])
11AC_CONFIG_FILES([Makefile minizip.pc]) 21AC_CONFIG_FILES([Makefile minizip.pc])