summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7eefa49..a64fe0b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,7 +20,7 @@ check_include_file(stddef.h HAVE_STDDEF_H)
20# 20#
21# Check to see if we have large file support 21# Check to see if we have large file support
22# 22#
23set(CMAKE_REQUIRED_DEFINITIONS -D_LARGEFILE64_SOURCE) 23set(CMAKE_REQUIRED_DEFINITIONS -D_LARGEFILE64_SOURCE=1)
24# We add these other definitions here because CheckTypeSize.cmake 24# We add these other definitions here because CheckTypeSize.cmake
25# in CMake 2.4.x does not automatically do so and we want 25# in CMake 2.4.x does not automatically do so and we want
26# compatibility with CMake 2.4.x. 26# compatibility with CMake 2.4.x.
@@ -35,7 +35,7 @@ if(HAVE_STDDEF_H)
35endif() 35endif()
36check_type_size(off64_t OFF64_T) 36check_type_size(off64_t OFF64_T)
37if(HAVE_OFF64_T) 37if(HAVE_OFF64_T)
38 add_definitions(-D_LARGEFILE64_SOURCE) 38 add_definitions(-D_LARGEFILE64_SOURCE=1)
39endif() 39endif()
40set(CMAKE_REQUIRED_DEFINITIONS) # clear variable 40set(CMAKE_REQUIRED_DEFINITIONS) # clear variable
41 41
@@ -52,13 +52,6 @@ endif()
52# 52#
53check_include_file(unistd.h Z_HAVE_UNISTD_H) 53check_include_file(unistd.h Z_HAVE_UNISTD_H)
54 54
55#
56# Check for errno.h
57check_include_file(errno.h HAVE_ERRNO_H)
58if(NOT HAVE_ERRNO_H)
59 add_definitions(-DNO_ERRNO_H)
60endif()
61
62if(MSVC) 55if(MSVC)
63 set(CMAKE_DEBUG_POSTFIX "d") 56 set(CMAKE_DEBUG_POSTFIX "d")
64 add_definitions(-D_CRT_SECURE_NO_DEPRECATE) 57 add_definitions(-D_CRT_SECURE_NO_DEPRECATE)