summaryrefslogtreecommitdiff
path: root/busybox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'busybox.spec')
-rw-r--r--busybox.spec43
1 files changed, 43 insertions, 0 deletions
diff --git a/busybox.spec b/busybox.spec
new file mode 100644
index 000000000..46bd7f484
--- /dev/null
+++ b/busybox.spec
@@ -0,0 +1,43 @@
1Name: busybox
2Version: 0.29alpha
3Release: 1
4Group: System/Utilities
5Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
6Copyright: GPL
7Packager : Erik Andersen <andersen@lineo.com>
8Conflicts: fileutils grep shellutils
9Buildroot: /tmp/%{Name}-%{Version}
10Source: busybox-0.29a1.tar.gz
11
12%Description
13BusyBox is a suite of "tiny" Unix utilities in a multi-call binary. It
14provides a pretty complete environment that fits on a floppy or in a
15ROM. Just add "ash" (Keith Almquists tiny Bourne shell clone) and "ae",
16and a kernel and you have a full system. This is used on the Debian
17install disk and in an internet router, and it makes a good environment
18for a "rescue" disk or any small or embedded system.
19
20%Prep
21%setup -q -n busybox
22
23%Build
24make
25
26%Install
27rm -rf $RPM_BUILD_ROOT
28mkdir -p $RPM_BUILD_ROOT/bin
29h=`cat busybox.links`
30
31for i in $h ; do
32 mkdir -p $RPM_BUILD_ROOT/`echo $i | sed -e 's/\(^.*\/\)\(.*\)/\1/g' `
33 (cd $RPM_BUILD_ROOT/bin ; ln -s ln `echo $i | sed -e 's/\(^.*\/\)\(.*\)/\2/g' ` );
34done
35rm -f $RPM_BUILD_ROOT/bin/ln
36install -m 755 busybox $RPM_BUILD_ROOT/bin/ln
37
38%Clean
39rm -rf $RPM_BUILD_ROOT
40
41%Files
42%defattr(-,root,root)
43/