aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimothy Gu <timothygu99@gmail.com>2014-12-21 12:45:58 -0800
committerTimothy Gu <timothygu99@gmail.com>2014-12-21 12:45:58 -0800
commitb87558a055897891d1c9f26e867d636d833ee55e (patch)
tree80cfc14857ee552cfd5242a815f34ed98cd19359 /Makefile.am
parent2d6c00722652589b6c2532d9e9a43417d29612c1 (diff)
downloaddlfcn-win32-lib-exp.tar.gz
dlfcn-win32-lib-exp.tar.bz2
dlfcn-win32-lib-exp.zip
WIP autoolslib-exp
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c8ce13..0a6605a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,5 +2,18 @@ ACLOCAL_AMFLAGS = -I m4
2 2
3lib_LTLIBRARIES = libdl.la 3lib_LTLIBRARIES = libdl.la
4libdl_la_SOURCES = dlfcn.c 4libdl_la_SOURCES = dlfcn.c
5libdl_la_LDFLAGS = -no-undefined 5# Don't build libdl as libdl-0.dll
6include_HEADERS = dlfcn.h \ No newline at end of file 6libdl_la_LDFLAGS = -avoid-version -no-undefined @GEN_DEF@
7include_HEADERS = dlfcn.h
8
9$(lib_LTLIBRARIES): @LIBDL_MSVC_LIB@
10
11libdl.lib:
12 $(MSVCLIB) -def:libdl.def -out:libdl.lib
13
14install-exec:: @EXTRA_INSTALL@
15
16install-msvc-lib:
17 mkdir -p "$(DESTDIR)$(libdir)"
18 @echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(libdir)'"
19 $(INSTALL_DATA) libdl.lib "$(DESTDIR)$(libdir)"