diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..596e496 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,17 @@ | |||
1 | cmake_minimum_required ( VERSION 2.8 ) | ||
2 | |||
3 | project ( lua-llthreads2 C ) | ||
4 | include ( cmake/dist.cmake ) | ||
5 | include ( lua ) | ||
6 | |||
7 | set ( CMAKE_THREAD_PREFER_PTHREAD TRUE ) | ||
8 | include ( FindThreads ) | ||
9 | |||
10 | include_directories ( ${CMAKE_CURRENT_SOURCE_DIR}/llthreads2/src ) | ||
11 | |||
12 | set ( LUA_LLTHREADS_SRC llthreads2/src/l52util.c llthreads2/src/llthread.c ) | ||
13 | |||
14 | install_lua_module ( llthreads2 ${LUA_LLTHREADS_SRC} LINK ${CMAKE_THREAD_LIBS_INIT} ) | ||
15 | |||
16 | install_data ( llthreads2/COPYRIGHT.llthreads llthreads2/README.md llthreads2/LICENSE ) | ||
17 | install_test ( llthreads2/test/ ) | ||