Commit message (Expand) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | check C is independent from check B | Roberto Ierusalimschy | 2001-07-03 | 1 | -4/+5 |
* | new module lopcodes.c for tables describing opcodes | Roberto Ierusalimschy | 2001-06-28 | 1 | -50/+1 |
* | rename of `kproto' to `p' | Roberto Ierusalimschy | 2001-06-28 | 1 | -3/+3 |
* | too much optimization to "break" keys in tables; keep them as TObjects... | Roberto Ierusalimschy | 2001-06-26 | 1 | -3/+3 |
* | cleaner way to ensure alignment for strings and userdata | Roberto Ierusalimschy | 2001-06-15 | 1 | -3/+3 |
* | details about opcode parameters | Roberto Ierusalimschy | 2001-06-11 | 1 | -48/+48 |
* | new definition for `luaD_call' and `luaD_adjusttop' | Roberto Ierusalimschy | 2001-06-08 | 1 | -2/+2 |
* | details. | Roberto Ierusalimschy | 2001-06-08 | 1 | -9/+3 |
* | details (rests of debug code) | Roberto Ierusalimschy | 2001-06-07 | 1 | -5/+1 |
* | details | Roberto Ierusalimschy | 2001-06-07 | 1 | -2/+2 |
* | new implementation for the Virtual Machine | Roberto Ierusalimschy | 2001-06-05 | 1 | -165/+195 |
* | list constructors do not adjust last expression | Roberto Ierusalimschy | 2001-04-06 | 1 | -5/+5 |
* | new way to handle `profiles' | Roberto Ierusalimschy | 2001-03-26 | 1 | -1/+2 |
* | better way to link callinfo's and stack | Roberto Ierusalimschy | 2001-03-07 | 1 | -99/+75 |
* | optimization for tailcall does not seem to pay itself | Roberto Ierusalimschy | 2001-03-07 | 1 | -12/+4 |
* | sizeof(string) != strlen(string)+1 when sizeof(char) != 1 | Roberto Ierusalimschy | 2001-03-06 | 1 | -2/+2 |
* | lower-case for macros with arguments | Roberto Ierusalimschy | 2001-03-02 | 1 | -13/+13 |
* | buffer should be void *, as char now is not that neutral... | Roberto Ierusalimschy | 2001-02-23 | 1 | -2/+2 |
* | first (big) step to support wide chars | Roberto Ierusalimschy | 2001-02-23 | 1 | -40/+40 |
* | avoid '...' and "..." inside comments | Roberto Ierusalimschy | 2001-02-22 | 1 | -2/+2 |
* | warnings from Visual C++ | Roberto Ierusalimschy | 2001-02-21 | 1 | -3/+3 |
* | code check for upvalues | Roberto Ierusalimschy | 2001-02-20 | 1 | -3/+4 |
* | better separation between basic types | Roberto Ierusalimschy | 2001-02-20 | 1 | -4/+4 |
* | better strucuture for code checker | Roberto Ierusalimschy | 2001-02-16 | 1 | -46/+49 |
* | checking consistency of jumps (and some other details) | Roberto Ierusalimschy | 2001-02-12 | 1 | -26/+75 |
* | string pointers are always fully aligned | Roberto Ierusalimschy | 2001-02-09 | 1 | -5/+5 |
* | first version of code verification | Roberto Ierusalimschy | 2001-02-09 | 1 | -46/+123 |
* | new way to handle top x L->top | Roberto Ierusalimschy | 2001-02-07 | 1 | -8/+10 |
* | lock/unlock may use L + better structure for internal debug stuff | Roberto Ierusalimschy | 2001-02-02 | 1 | -13/+13 |
* | smaller tables for machines with 8-bit alignment | Roberto Ierusalimschy | 2001-01-29 | 1 | -3/+3 |
* | new macros + new names to facilitate compilation of threaded version | Roberto Ierusalimschy | 2001-01-26 | 1 | -13/+13 |
* | first implementation for type names | Roberto Ierusalimschy | 2001-01-25 | 1 | -4/+4 |
* | macros LUA_ENTRY/LUA_EXIT to control exclusive access to Lua core | Roberto Ierusalimschy | 2001-01-24 | 1 | -22/+51 |
* | thead-specific state separated from "global" state | Roberto Ierusalimschy | 2001-01-19 | 1 | -19/+18 |
* | all accesses to TObjects done through macros | Roberto Ierusalimschy | 2001-01-18 | 1 | -6/+5 |
* | explicit control of size for growing vectors | Roberto Ierusalimschy | 2000-12-26 | 1 | -2/+2 |
* | better control over extensions of char/short to int | Roberto Ierusalimschy | 2000-11-30 | 1 | -2/+2 |
* | all API functions are declared in a single line (to facilitate pre-processing). | Roberto Ierusalimschy | 2000-10-30 | 1 | -9/+7 |
* | details | Roberto Ierusalimschy | 2000-10-27 | 1 | -2/+2 |
* | new macro LUA_API | Roberto Ierusalimschy | 2000-10-20 | 1 | -21/+23 |
* | better treatment for source names | Roberto Ierusalimschy | 2000-10-09 | 1 | -2/+2 |
* | luaD_call is more uniform | Roberto Ierusalimschy | 2000-10-06 | 1 | -4/+7 |
* | tag methods are always functions, so don't need to store a whole object | Roberto Ierusalimschy | 2000-10-05 | 1 | -7/+9 |
* | new definition for types-tags | Roberto Ierusalimschy | 2000-10-05 | 1 | -39/+40 |
* | new API function `lua_type' + new type lua_Type | Roberto Ierusalimschy | 2000-10-02 | 1 | -5/+5 |
* | small "by 1" bug | Roberto Ierusalimschy | 2000-09-18 | 1 | -2/+2 |
* | better name for source_id (short_src) | Roberto Ierusalimschy | 2000-09-12 | 1 | -2/+2 |
* | `lauxlib' is now part of the libraries (not used by core Lua) | Roberto Ierusalimschy | 2000-09-11 | 1 | -12/+16 |
* | errors may happen before function start running (with pc=-1) | Roberto Ierusalimschy | 2000-08-31 | 1 | -5/+13 |
* | L is not unused. | Roberto Ierusalimschy | 2000-08-28 | 1 | -2/+1 |