Commit message (Expand) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | version -> 4.1 alpha | Roberto Ierusalimschy | 2001-07-19 | 1 | -2/+2 |
* | better names for type-related functions | Roberto Ierusalimschy | 2001-07-12 | 1 | -27/+24 |
* | LUA_MINSTACK has a fixed value | Roberto Ierusalimschy | 2001-07-05 | 1 | -5/+4 |
* | new macro to control format for `read"*n"' | Roberto Ierusalimschy | 2001-06-28 | 1 | -3/+9 |
* | new implementation for userdatas, without `keys' | Roberto Ierusalimschy | 2001-06-06 | 1 | -2/+2 |
* | name changes | Roberto Ierusalimschy | 2001-04-23 | 1 | -7/+16 |
* | re-implementation of refs through weak tables | Roberto Ierusalimschy | 2001-04-17 | 1 | -12/+13 |
* | new API functions to load (parse?) a chunk without running it. | Roberto Ierusalimschy | 2001-04-11 | 1 | -2/+5 |
* | first implementation for weak tables | Roberto Ierusalimschy | 2001-04-11 | 1 | -2/+10 |
* | avoid use of l_char outside INTERNALs (use lua_char instead) | Roberto Ierusalimschy | 2001-04-06 | 1 | -29/+31 |
* | new way to handle `profiles' | Roberto Ierusalimschy | 2001-03-26 | 1 | -10/+59 |
* | old signature for lua_open | Roberto Ierusalimschy | 2001-03-09 | 1 | -2/+4 |
* | details for wchar | Roberto Ierusalimschy | 2001-02-23 | 1 | -5/+5 |
* | first (big) step to support wide chars | Roberto Ierusalimschy | 2001-02-23 | 1 | -19/+22 |
* | better encapsulation of some types | Roberto Ierusalimschy | 2001-02-22 | 1 | -9/+10 |
* | better separation between basic types | Roberto Ierusalimschy | 2001-02-20 | 1 | -2/+3 |
* | new semantics for pushuserdata (no more different userdatas with same value) | Roberto Ierusalimschy | 2001-02-09 | 1 | -4/+3 |
* | new macros + new names to facilitate compilation of threaded version | Roberto Ierusalimschy | 2001-01-26 | 1 | -6/+16 |
* | first implementation for type names | Roberto Ierusalimschy | 2001-01-25 | 1 | -2/+8 |
* | support for multiple stacks sharing the same global environment | Roberto Ierusalimschy | 2001-01-22 | 1 | -2/+2 |
* | new macro pushliteral | Roberto Ierusalimschy | 2001-01-10 | 1 | -2/+4 |
* | temporary version | Roberto Ierusalimschy | 2000-12-22 | 1 | -2/+2 |
* | lua_Number defined in lua.h (1st version) | Roberto Ierusalimschy | 2000-12-04 | 1 | -3/+6 |
* | comments | Roberto Ierusalimschy | 2000-10-31 | 1 | -2/+2 |
* | all API functions are declared in a single line (to facilitate pre-processing). | Roberto Ierusalimschy | 2000-10-30 | 1 | -6/+7 |
* | new API function `createuserdata' | Roberto Ierusalimschy | 2000-10-26 | 1 | -1/+3 |
* | registry mechanism | Roberto Ierusalimschy | 2000-10-24 | 1 | -1/+7 |
* | new macro LUA_API | Roberto Ierusalimschy | 2000-10-20 | 1 | -61/+66 |
* | better treatment for errors inside _ERRORMETHOD | Roberto Ierusalimschy | 2000-10-09 | 1 | -1/+2 |
* | new definition for types-tags | Roberto Ierusalimschy | 2000-10-05 | 1 | -8/+15 |
* | new API function `lua_type' + new type lua_Type | Roberto Ierusalimschy | 2000-10-02 | 1 | -8/+16 |
* | new API for garbage collector | Roberto Ierusalimschy | 2000-10-02 | 1 | -3/+7 |
* | details | Roberto Ierusalimschy | 2000-09-18 | 1 | -9/+9 |
* | new API function lua_rawget | Roberto Ierusalimschy | 2000-09-14 | 1 | -1/+2 |
* | _ALERT is used (and assumed) only by the libs | Roberto Ierusalimschy | 2000-09-12 | 1 | -3/+2 |
* | `lua_newstate' renamed to `lua_open' | Roberto Ierusalimschy | 2000-09-11 | 1 | -3/+3 |
* | new version for API | Roberto Ierusalimschy | 2000-09-05 | 1 | -10/+14 |
* | more builtin functions using official API | Roberto Ierusalimschy | 2000-08-31 | 1 | -1/+3 |
* | new API functions `pop', `insert', and `move' | Roberto Ierusalimschy | 2000-08-31 | 1 | -1/+5 |
* | new implementation for `next' | Roberto Ierusalimschy | 2000-08-31 | 1 | -3/+4 |
* | explicit stack control in the API | Roberto Ierusalimschy | 2000-08-29 | 1 | -1/+5 |
* | C upvalues are the last arguments to a function | Roberto Ierusalimschy | 2000-08-29 | 1 | -2/+2 |
* | first version for new API | Roberto Ierusalimschy | 2000-08-28 | 1 | -173/+78 |
* | `pushref' is more efficient (and probably more useful) than `getref'. | Roberto Ierusalimschy | 2000-08-17 | 1 | -5/+5 |
* | new name for `lua_[sg]etglobaltable' | Roberto Ierusalimschy | 2000-08-14 | 1 | -5/+5 |
* | default now is multi-state | Roberto Ierusalimschy | 2000-08-09 | 1 | -5/+5 |
* | (much) better handling of memory alloction errors | Roberto Ierusalimschy | 2000-08-07 | 1 | -3/+11 |
* | no varargs in Lua API | Roberto Ierusalimschy | 2000-06-30 | 1 | -3/+3 |
* | functions `for...' and `raw...' are obsolete now | Roberto Ierusalimschy | 2000-05-26 | 1 | -10/+27 |
* | code cleaner for 16 bits. | Roberto Ierusalimschy | 2000-05-24 | 1 | -5/+10 |