summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorwilliam <william@25tandclement.com>2013-12-09 21:20:00 -0800
committerwilliam <william@25tandclement.com>2013-12-09 21:20:00 -0800
commit9db41e05d9a00eb906b530b38bcaaa068d40c88b (patch)
tree71312908cae28d36543f8881bc675f8867380eee /debian
parentfbd452885694da66156e95f671ab364cfe157bef (diff)
downloadluaossl-9db41e05d9a00eb906b530b38bcaaa068d40c88b.tar.gz
luaossl-9db41e05d9a00eb906b530b38bcaaa068d40c88b.tar.bz2
luaossl-9db41e05d9a00eb906b530b38bcaaa068d40c88b.zip
add debian packaging files
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright23
-rw-r--r--debian/liblua5.1-openssl.files2
-rw-r--r--debian/liblua5.1-openssl.install2
-rw-r--r--debian/liblua5.2-openssl.files2
-rw-r--r--debian/liblua5.2-openssl.install2
-rwxr-xr-xdebian/rules26
9 files changed, 79 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..4d5e440
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
1liblua-openssl (20131209-1) unstable; urgency=low
2
3 * Initial release after splitting from cqueues project.
4
5 -- William Ahern <william@25thandClement.com> Sun, 09 Dec 2013 21:17:33 -0800
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..a17b827
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
1Source: liblua-openssl
2Section: unknown
3Priority: extra
4Maintainer: William Ahern <william@25thandClement.com>
5Build-Depends: debhelper (>= 9), m4, dh-lua, libssl-dev
6Standards-Version: 3.9.2
7
8Package: liblua5.1-openssl
9Architecture: any
10Depends: openssl, liblua5.1-0
11Description: Comprehensive OpenSSL bindings.
12
13Package: liblua5.2-openssl
14Architecture: any
15Depends: openssl, liblua5.2-0
16Description: Comprehensive OpenSSL bindings.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..d4958f8
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,23 @@
1Author: William Ahern <william@25thandClement.com>
2Download: http://25thandclement.com/~william/projects/luaossl.html
3
4Files: *
5Copyright: © 2012-2013, William Ahern
6License: MIT
7Permission is hereby granted, free of charge, to any person obtaining a copy
8of this software and associated documentation files (the "Software"), to
9deal in the Software without restriction, including without limitation the
10rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
11sell copies of the Software, and to permit persons to whom the Software is
12furnished to do so, subject to the following conditions:
13
14The above copyright notice and this permission notice shall be included in
15all copies or substantial portions of the Software.
16
17THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
18IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
19FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
20AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
21LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
22FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
23IN THE SOFTWARE.
diff --git a/debian/liblua5.1-openssl.files b/debian/liblua5.1-openssl.files
new file mode 100644
index 0000000..84e8b8f
--- /dev/null
+++ b/debian/liblua5.1-openssl.files
@@ -0,0 +1,2 @@
1usr/lib/lua/5.1/_openssl.so
2usr/share/lua/5.1/openssl*
diff --git a/debian/liblua5.1-openssl.install b/debian/liblua5.1-openssl.install
new file mode 100644
index 0000000..325a01a
--- /dev/null
+++ b/debian/liblua5.1-openssl.install
@@ -0,0 +1,2 @@
1debian/tmp/usr/lib/lua/5.1/_openssl.so usr/lib/lua/5.1
2debian/tmp/usr/share/lua/5.1/openssl* usr/share/lua/5.1
diff --git a/debian/liblua5.2-openssl.files b/debian/liblua5.2-openssl.files
new file mode 100644
index 0000000..e513b8d
--- /dev/null
+++ b/debian/liblua5.2-openssl.files
@@ -0,0 +1,2 @@
1usr/lib/lua/5.2/_openssl.so
2usr/share/lua/5.2/openssl*
diff --git a/debian/liblua5.2-openssl.install b/debian/liblua5.2-openssl.install
new file mode 100644
index 0000000..595dc7f
--- /dev/null
+++ b/debian/liblua5.2-openssl.install
@@ -0,0 +1,2 @@
1debian/tmp/usr/lib/lua/5.2/_openssl.so usr/lib/lua/5.2
2debian/tmp/usr/share/lua/5.2/openssl* usr/share/lua/5.2
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..10c05a8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
1#!/usr/bin/make -f
2
3CFLAGS := -O3 -g -fstack-protector --param=ssp-buffer-size=4
4
5DESTDIR=debian/tmp
6prefix=/usr
7build=liblua5.1-openssl liblua5.2-openssl
8install=$(addsuffix -install,$(build))
9
10%:
11 dh $@
12
13override_dh_auto_configure:
14 true
15
16override_dh_auto_build:
17 make DESTDIR=$(DESTDIR) prefix=$(prefix) $(build)
18
19override_dh_auto_install:
20 make DESTDIR=$(DESTDIR) prefix=$(prefix) $(install)
21
22override_dh_auto_clean:
23 make clean
24
25override_dh_auto_test:
26 true