diff options
author | d3x0r <d3x0r@users.noreply.github.com> | 2017-07-06 01:49:43 -0700 |
---|---|---|
committer | d3x0r <d3x0r@users.noreply.github.com> | 2017-07-06 01:49:43 -0700 |
commit | a2bd5ebaba789822ae73e9059171c46ed6b8f574 (patch) | |
tree | a201fa8fa7a16438b7967121724c1f0367a8d6e2 /tls/CMakeLists.txt | |
parent | 728bda183018cbc9736f03d4f21d2b4a2585e83d (diff) | |
download | portable-a2bd5ebaba789822ae73e9059171c46ed6b8f574.tar.gz portable-a2bd5ebaba789822ae73e9059171c46ed6b8f574.tar.bz2 portable-a2bd5ebaba789822ae73e9059171c46ed6b8f574.zip |
use GNUInstallDirs from cmake to specify install paths.
Primarily this is to select whether 'lib64' or 'lib' is used on linux type systems.
Diffstat (limited to 'tls/CMakeLists.txt')
-rw-r--r-- | tls/CMakeLists.txt | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/tls/CMakeLists.txt b/tls/CMakeLists.txt index b71fb37..c3e6336 100644 --- a/tls/CMakeLists.txt +++ b/tls/CMakeLists.txt | |||
@@ -39,9 +39,9 @@ if (BUILD_SHARED) | |||
39 | ARCHIVE_OUTPUT_NAME tls${TLS_POSTFIX}) | 39 | ARCHIVE_OUTPUT_NAME tls${TLS_POSTFIX}) |
40 | set_target_properties(tls-shared PROPERTIES VERSION ${TLS_VERSION} | 40 | set_target_properties(tls-shared PROPERTIES VERSION ${TLS_VERSION} |
41 | SOVERSION ${TLS_MAJOR_VERSION}) | 41 | SOVERSION ${TLS_MAJOR_VERSION}) |
42 | install(TARGETS tls tls-shared DESTINATION lib) | 42 | install(TARGETS tls tls-shared DESTINATION ${CMAKE_INSTALL_LIBDIR}) |
43 | else() | 43 | else() |
44 | add_library(tls STATIC ${TLS_SRC}) | 44 | add_library(tls STATIC ${TLS_SRC}) |
45 | install(TARGETS tls DESTINATION lib) | 45 | install(TARGETS tls DESTINATION ${CMAKE_INSTALL_LIBDIR}) |
46 | endif() | 46 | endif() |
47 | 47 | ||