aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51e35a8..e92b602 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,11 @@ case $host_os in
22 HOST_ABI=elf 22 HOST_ABI=elf
23 AC_SUBST([PROG_LDADD], ['-lthr']) 23 AC_SUBST([PROG_LDADD], ['-lthr'])
24 ;; 24 ;;
25 *hpux*)
26 HOST_OS=hpux;
27 CFLAGS="$CFLAGS -mlp64 -D_XOPEN_SOURCE=600 -D__STRICT_ALIGNMENT"
28 AC_SUBST([PLATFORM_LDADD], ['-lpthread'])
29 ;;
25 *linux*) 30 *linux*)
26 HOST_OS=linux 31 HOST_OS=linux
27 HOST_ABI=elf 32 HOST_ABI=elf
@@ -53,6 +58,7 @@ esac
53 58
54AM_CONDITIONAL([HOST_DARWIN], [test x$HOST_OS = xdarwin]) 59AM_CONDITIONAL([HOST_DARWIN], [test x$HOST_OS = xdarwin])
55AM_CONDITIONAL([HOST_FREEBSD], [test x$HOST_OS = xfreebsd]) 60AM_CONDITIONAL([HOST_FREEBSD], [test x$HOST_OS = xfreebsd])
61AM_CONDITIONAL([HOST_HPUX], [test x$HOST_OS = xhpux])
56AM_CONDITIONAL([HOST_LINUX], [test x$HOST_OS = xlinux]) 62AM_CONDITIONAL([HOST_LINUX], [test x$HOST_OS = xlinux])
57AM_CONDITIONAL([HOST_SOLARIS], [test x$HOST_OS = xsolaris]) 63AM_CONDITIONAL([HOST_SOLARIS], [test x$HOST_OS = xsolaris])
58AM_CONDITIONAL([HOST_WIN], [test x$HOST_OS = xwin]) 64AM_CONDITIONAL([HOST_WIN], [test x$HOST_OS = xwin])