aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e56e39d..bdb015b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,7 +57,6 @@ AC_CHECK_FUNC([clock_gettime],,
57AC_CHECK_FUNC([dl_iterate_phdr],, 57AC_CHECK_FUNC([dl_iterate_phdr],,
58 [AC_SEARCH_LIBS([dl_iterate_phdr],[dl])]) 58 [AC_SEARCH_LIBS([dl_iterate_phdr],[dl])])
59 59
60AM_PROG_AS
61AC_PROG_CC 60AC_PROG_CC
62AC_PROG_LIBTOOL 61AC_PROG_LIBTOOL
63AC_PROG_CC_STDC 62AC_PROG_CC_STDC
@@ -73,6 +72,18 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
73) 72)
74CFLAGS="$save_cflags $AM_CFLAGS" 73CFLAGS="$save_cflags $AM_CFLAGS"
75 74
75save_cflags="$CFLAGS"
76CFLAGS=
77AC_MSG_CHECKING([whether AS supports .note.GNU-stack])
78AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
79__asm__(".section .note.GNU-stack,\"\",@progbits");]])],
80 [AC_MSG_RESULT([yes])]
81 [AM_CFLAGS=-DHAVE_GNU_STACK],
82 [AC_MSG_RESULT([no])]
83)
84CFLAGS="$save_cflags $AM_CFLAGS"
85AM_PROG_AS
86
76AC_MSG_CHECKING([if compiling with clang]) 87AC_MSG_CHECKING([if compiling with clang])
77AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [[ 88AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [[
78#ifndef __clang__ 89#ifndef __clang__