aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 54209da..d8e5338 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,9 @@ case $host_os in
32 HOST_ABI=elf 32 HOST_ABI=elf
33 CFLAGS="$CFLAGS -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_SOURCE -D_GNU_SOURCE" 33 CFLAGS="$CFLAGS -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_SOURCE -D_GNU_SOURCE"
34 ;; 34 ;;
35 *netbsd*)
36 HOST_OS=netbsd
37 ;;
35 *openbsd*) 38 *openbsd*)
36 HOST_ABI=elf 39 HOST_ABI=elf
37 AC_DEFINE([HAVE_ATTRIBUTE__BOUNDED__], [1], [OpenBSD gcc has bounded]) 40 AC_DEFINE([HAVE_ATTRIBUTE__BOUNDED__], [1], [OpenBSD gcc has bounded])
@@ -60,6 +63,7 @@ AM_CONDITIONAL([HOST_DARWIN], [test x$HOST_OS = xdarwin])
60AM_CONDITIONAL([HOST_FREEBSD], [test x$HOST_OS = xfreebsd]) 63AM_CONDITIONAL([HOST_FREEBSD], [test x$HOST_OS = xfreebsd])
61AM_CONDITIONAL([HOST_HPUX], [test x$HOST_OS = xhpux]) 64AM_CONDITIONAL([HOST_HPUX], [test x$HOST_OS = xhpux])
62AM_CONDITIONAL([HOST_LINUX], [test x$HOST_OS = xlinux]) 65AM_CONDITIONAL([HOST_LINUX], [test x$HOST_OS = xlinux])
66AM_CONDITIONAL([HOST_NETBSD], [test x$HOST_OS = xnetbsd])
63AM_CONDITIONAL([HOST_SOLARIS], [test x$HOST_OS = xsolaris]) 67AM_CONDITIONAL([HOST_SOLARIS], [test x$HOST_OS = xsolaris])
64AM_CONDITIONAL([HOST_WIN], [test x$HOST_OS = xwin]) 68AM_CONDITIONAL([HOST_WIN], [test x$HOST_OS = xwin])
65 69
@@ -214,7 +218,10 @@ AM_CONDITIONAL([HAVE_TIMINGSAFE_MEMCMP], [test "x$ac_cv_func_timingsafe_memcmp"
214 218
215# overrides for arc4random_buf implementations with known issues 219# overrides for arc4random_buf implementations with known issues
216AM_CONDITIONAL([HAVE_ARC4RANDOM_BUF], 220AM_CONDITIONAL([HAVE_ARC4RANDOM_BUF],
217 [test "x$HOST_OS" != xdarwin -a "x$HOST_OS" != xfreebsd -a "x$ac_cv_func_arc4random_buf" = xyes]) 221 [test "x$HOST_OS" != xdarwin \
222 -a "x$HOST_OS" != xfreebsd \
223 -a "x$HOST_OS" != xnetbsd \
224 -a "x$ac_cv_func_arc4random_buf" = xyes])
218 225
219AC_CACHE_CHECK([whether va_copy exists], ac_cv_have_va_copy, [ 226AC_CACHE_CHECK([whether va_copy exists], ac_cv_have_va_copy, [
220 AC_LINK_IFELSE([AC_LANG_PROGRAM([[ 227 AC_LINK_IFELSE([AC_LANG_PROGRAM([[