diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 15 |
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac index f3d7c77..51e096b 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -77,9 +77,9 @@ AS_CASE([$host_cpu], | |||
77 | [arm64], [host_cpu=aarch64], | 77 | [arm64], [host_cpu=aarch64], |
78 | [*arm*], [host_cpu=arm], | 78 | [*arm*], [host_cpu=arm], |
79 | [*amd64*], [host_cpu=x86_64 HOSTARCH=intel], | 79 | [*amd64*], [host_cpu=x86_64 HOSTARCH=intel], |
80 | [i?86], [host_cpu=i386 HOSTARCH=intel], | 80 | [i?86], [host_cpu=i386 HOSTARCH=intel enable_asm=no], |
81 | [mipsel*], [host_cpu=mips], | 81 | [mips64*], [host_cpu=mips64 enable_asm=no], |
82 | [mips64el*], [host_cpu=mips64], | 82 | [mips*], [host_cpu=mips enable_asm=no], |
83 | [powerpc*], [host_cpu=powerpc], | 83 | [powerpc*], [host_cpu=powerpc], |
84 | [ppc64*], [host_cpu=powerpc64], | 84 | [ppc64*], [host_cpu=powerpc64], |
85 | [x86_64], [HOSTARCH=intel] | 85 | [x86_64], [HOSTARCH=intel] |
@@ -109,13 +109,16 @@ int main() {return 0;} | |||
109 | AC_MSG_RESULT(no) | 109 | AC_MSG_RESULT(no) |
110 | ]) | 110 | ]) |
111 | 111 | ||
112 | AC_ARG_ENABLE([asm], | 112 | AC_ARG_ENABLE([asm], AS_HELP_STRING([--disable-asm], [Disable assembly])) |
113 | AS_HELP_STRING([--disable-asm], [Disable assembly])) | 113 | AM_CONDITIONAL([OPENSSL_NO_ASM], [test "x$enable_asm" = "xno"]) |
114 | AM_CONDITIONAL([OPENSSL_NO_ASM], [test "x$enable_asm" = "xno" -o "$host_cpu" = "i386"]) | ||
115 | 114 | ||
116 | # Conditionally enable assembly by default | 115 | # Conditionally enable assembly by default |
117 | AM_CONDITIONAL([HOST_ASM_ELF_ARM], | 116 | AM_CONDITIONAL([HOST_ASM_ELF_ARM], |
118 | [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "arm" -a "x$enable_asm" != "xno"]) | 117 | [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "arm" -a "x$enable_asm" != "xno"]) |
118 | AM_CONDITIONAL([HOST_ASM_ELF_MIPS], | ||
119 | [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "mips" -a "x$enable_asm" != "xno"]) | ||
120 | AM_CONDITIONAL([HOST_ASM_ELF_MIPS64], | ||
121 | [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "mips64" -a "x$enable_asm" != "xno"]) | ||
119 | AM_CONDITIONAL([HOST_ASM_ELF_X86_64], | 122 | AM_CONDITIONAL([HOST_ASM_ELF_X86_64], |
120 | [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"]) | 123 | [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"]) |
121 | AM_CONDITIONAL([HOST_ASM_MACOSX_X86_64], | 124 | AM_CONDITIONAL([HOST_ASM_MACOSX_X86_64], |