aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 67266cb..75a1ec2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,10 @@ LT_INIT
18CFLAGS="$CFLAGS -Wall -std=gnu99" 18CFLAGS="$CFLAGS -Wall -std=gnu99"
19 19
20case $host_os in 20case $host_os in
21 *aix*)
22 HOST_OS=aix
23 AC_SUBST([PLATFORM_LDADD], ['-lperfstat -lpthread'])
24 ;;
21 *cygwin*) 25 *cygwin*)
22 HOST_OS=cygwin 26 HOST_OS=cygwin
23 ;; 27 ;;
@@ -68,6 +72,7 @@ case $host_os in
68 *) ;; 72 *) ;;
69esac 73esac
70 74
75AM_CONDITIONAL([HOST_AIX], [test x$HOST_OS = xaix])
71AM_CONDITIONAL([HOST_CYGWIN], [test x$HOST_OS = xcygwin]) 76AM_CONDITIONAL([HOST_CYGWIN], [test x$HOST_OS = xcygwin])
72AM_CONDITIONAL([HOST_DARWIN], [test x$HOST_OS = xdarwin]) 77AM_CONDITIONAL([HOST_DARWIN], [test x$HOST_OS = xdarwin])
73AM_CONDITIONAL([HOST_FREEBSD], [test x$HOST_OS = xfreebsd]) 78AM_CONDITIONAL([HOST_FREEBSD], [test x$HOST_OS = xfreebsd])