aboutsummaryrefslogtreecommitdiff
path: root/ssl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ssl/Makefile.am')
-rw-r--r--ssl/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/ssl/Makefile.am b/ssl/Makefile.am
index a7a7d72..2c84bff 100644
--- a/ssl/Makefile.am
+++ b/ssl/Makefile.am
@@ -114,3 +114,59 @@ noinst_HEADERS += tls12_internal.h
114noinst_HEADERS += tls13_internal.h 114noinst_HEADERS += tls13_internal.h
115noinst_HEADERS += tls13_handshake.h 115noinst_HEADERS += tls13_handshake.h
116noinst_HEADERS += tls13_record.h 116noinst_HEADERS += tls13_record.h
117
118# arch
119if HOST_AARCH64
120libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/aarch64/
121endif
122noinst_HEADERS += $(top_srcdir)/crypto/arch/aarch64/crypto_arch.h
123
124if HOST_ARM
125libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/arm/
126endif
127noinst_HEADERS += $(top_srcdir)/crypto/arch/arm/crypto_arch.h
128
129if HOST_I386
130libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/i386/
131endif
132noinst_HEADERS += $(top_srcdir)/crypto/arch/i386/crypto_arch.h
133
134if HOST_LOONGARCH64
135libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/loongarch64/
136endif
137noinst_HEADERS += $(top_srcdir)/crypto/arch/loongarch64/crypto_arch.h
138
139if HOST_MIPS
140libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/mips/
141endif
142noinst_HEADERS += $(top_srcdir)/crypto/arch/mips/crypto_arch.h
143
144if HOST_MIPS64
145libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/mips64/
146endif
147noinst_HEADERS += $(top_srcdir)/crypto/arch/mips64/crypto_arch.h
148
149if HOST_POWERPC
150libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/powerpc/
151endif
152noinst_HEADERS += $(top_srcdir)/crypto/arch/powerpc/crypto_arch.h
153
154if HOST_POWERPC64
155libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/powerpc64/
156endif
157noinst_HEADERS += $(top_srcdir)/crypto/arch/powerpc64/crypto_arch.h
158
159if HOST_RISCV64
160libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/riscv64/
161endif
162noinst_HEADERS += $(top_srcdir)/crypto/arch/riscv64/crypto_arch.h
163
164if HOST_SPARC64
165libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/sparc64/
166endif
167noinst_HEADERS += $(top_srcdir)/crypto/arch/sparc64/crypto_arch.h
168
169if HOST_X86_64
170libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/amd64/
171endif
172noinst_HEADERS += $(top_srcdir)/crypto/arch/amd64/crypto_arch.h