diff options
Diffstat (limited to 'ssl/Makefile.am')
-rw-r--r-- | ssl/Makefile.am | 56 |
1 files changed, 56 insertions, 0 deletions
diff --git a/ssl/Makefile.am b/ssl/Makefile.am index a7a7d72..2c84bff 100644 --- a/ssl/Makefile.am +++ b/ssl/Makefile.am | |||
@@ -114,3 +114,59 @@ noinst_HEADERS += tls12_internal.h | |||
114 | noinst_HEADERS += tls13_internal.h | 114 | noinst_HEADERS += tls13_internal.h |
115 | noinst_HEADERS += tls13_handshake.h | 115 | noinst_HEADERS += tls13_handshake.h |
116 | noinst_HEADERS += tls13_record.h | 116 | noinst_HEADERS += tls13_record.h |
117 | |||
118 | # arch | ||
119 | if HOST_AARCH64 | ||
120 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/aarch64/ | ||
121 | endif | ||
122 | noinst_HEADERS += $(top_srcdir)/crypto/arch/aarch64/crypto_arch.h | ||
123 | |||
124 | if HOST_ARM | ||
125 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/arm/ | ||
126 | endif | ||
127 | noinst_HEADERS += $(top_srcdir)/crypto/arch/arm/crypto_arch.h | ||
128 | |||
129 | if HOST_I386 | ||
130 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/i386/ | ||
131 | endif | ||
132 | noinst_HEADERS += $(top_srcdir)/crypto/arch/i386/crypto_arch.h | ||
133 | |||
134 | if HOST_LOONGARCH64 | ||
135 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/loongarch64/ | ||
136 | endif | ||
137 | noinst_HEADERS += $(top_srcdir)/crypto/arch/loongarch64/crypto_arch.h | ||
138 | |||
139 | if HOST_MIPS | ||
140 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/mips/ | ||
141 | endif | ||
142 | noinst_HEADERS += $(top_srcdir)/crypto/arch/mips/crypto_arch.h | ||
143 | |||
144 | if HOST_MIPS64 | ||
145 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/mips64/ | ||
146 | endif | ||
147 | noinst_HEADERS += $(top_srcdir)/crypto/arch/mips64/crypto_arch.h | ||
148 | |||
149 | if HOST_POWERPC | ||
150 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/powerpc/ | ||
151 | endif | ||
152 | noinst_HEADERS += $(top_srcdir)/crypto/arch/powerpc/crypto_arch.h | ||
153 | |||
154 | if HOST_POWERPC64 | ||
155 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/powerpc64/ | ||
156 | endif | ||
157 | noinst_HEADERS += $(top_srcdir)/crypto/arch/powerpc64/crypto_arch.h | ||
158 | |||
159 | if HOST_RISCV64 | ||
160 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/riscv64/ | ||
161 | endif | ||
162 | noinst_HEADERS += $(top_srcdir)/crypto/arch/riscv64/crypto_arch.h | ||
163 | |||
164 | if HOST_SPARC64 | ||
165 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/sparc64/ | ||
166 | endif | ||
167 | noinst_HEADERS += $(top_srcdir)/crypto/arch/sparc64/crypto_arch.h | ||
168 | |||
169 | if HOST_X86_64 | ||
170 | libssl_la_CPPFLAGS += -I$(top_srcdir)/crypto/arch/amd64/ | ||
171 | endif | ||
172 | noinst_HEADERS += $(top_srcdir)/crypto/arch/amd64/crypto_arch.h | ||