diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index a64fe0b..e173dd7 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -171,20 +171,20 @@ endif() | |||
171 | # Example binaries | 171 | # Example binaries |
172 | #============================================================================ | 172 | #============================================================================ |
173 | 173 | ||
174 | add_executable(example example.c) | 174 | add_executable(example test/example.c) |
175 | target_link_libraries(example zlib) | 175 | target_link_libraries(example zlib) |
176 | add_test(example example) | 176 | add_test(example example) |
177 | 177 | ||
178 | add_executable(minigzip minigzip.c) | 178 | add_executable(minigzip test/minigzip.c) |
179 | target_link_libraries(minigzip zlib) | 179 | target_link_libraries(minigzip zlib) |
180 | 180 | ||
181 | if(HAVE_OFF64_T) | 181 | if(HAVE_OFF64_T) |
182 | add_executable(example64 example.c) | 182 | add_executable(example64 test/example.c) |
183 | target_link_libraries(example64 zlib) | 183 | target_link_libraries(example64 zlib) |
184 | set_target_properties(example64 PROPERTIES COMPILE_FLAGS "-D_FILE_OFFSET_BITS=64") | 184 | set_target_properties(example64 PROPERTIES COMPILE_FLAGS "-D_FILE_OFFSET_BITS=64") |
185 | add_test(example64 example64) | 185 | add_test(example64 example64) |
186 | 186 | ||
187 | add_executable(minigzip64 minigzip.c) | 187 | add_executable(minigzip64 test/minigzip.c) |
188 | target_link_libraries(minigzip64 zlib) | 188 | target_link_libraries(minigzip64 zlib) |
189 | set_target_properties(minigzip64 PROPERTIES COMPILE_FLAGS "-D_FILE_OFFSET_BITS=64") | 189 | set_target_properties(minigzip64 PROPERTIES COMPILE_FLAGS "-D_FILE_OFFSET_BITS=64") |
190 | endif() | 190 | endif() |