aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4f2babc..814df18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,19 +65,6 @@ if(MSVC)
65 include_directories(${zlib_SOURCE_DIR}) 65 include_directories(${zlib_SOURCE_DIR})
66endif() 66endif()
67 67
68option(RENAME_ZCONF "Rename the zconf when building out of source" ON)
69if(NOT zlib_SOURCE_DIR STREQUAL zlib_BINARY_DIR AND RENAME_ZCONF)
70 # If we're doing an out of source build and the user has a zconf.h
71 # in their source tree...
72 if(EXISTS ${zlib_SOURCE_DIR}/zconf.h)
73 message(STATUS "Renaming")
74 message(STATUS " ${zlib_SOURCE_DIR}/zconf.h")
75 message(STATUS "to 'zconf.h.included' because this file is included with zlib")
76 message(STATUS "but CMake generates it automatically in the build directory.")
77 file(RENAME ${zlib_SOURCE_DIR}/zconf.h ${zlib_SOURCE_DIR}/zconf.h.included)
78 endif()
79endif()
80
81set(ZLIB_PC ${zlib_BINARY_DIR}/zlib.pc) 68set(ZLIB_PC ${zlib_BINARY_DIR}/zlib.pc)
82configure_file( ${zlib_SOURCE_DIR}/zlib.pc.cmakein 69configure_file( ${zlib_SOURCE_DIR}/zlib.pc.cmakein
83 ${ZLIB_PC} @ONLY) 70 ${ZLIB_PC} @ONLY)