diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 17 |
1 files changed, 1 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 814df18..00fe464 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -20,26 +20,11 @@ include(CheckCSourceCompiles) | |||
20 | include(GNUInstallDirs) | 20 | include(GNUInstallDirs) |
21 | enable_testing() | 21 | enable_testing() |
22 | 22 | ||
23 | check_include_file(sys/types.h HAVE_SYS_TYPES_H) | ||
24 | check_include_file(stdint.h HAVE_STDINT_H) | ||
25 | check_include_file(stddef.h HAVE_STDDEF_H) | ||
26 | |||
27 | # | 23 | # |
28 | # Check to see if we have large file support | 24 | # Check to see if we have large file support |
29 | # | 25 | # |
30 | set(CMAKE_REQUIRED_DEFINITIONS -D_LARGEFILE64_SOURCE=1) | 26 | set(CMAKE_REQUIRED_DEFINITIONS -D_LARGEFILE64_SOURCE=1) |
31 | # We add these other definitions here because CheckTypeSize.cmake | 27 | |
32 | # in CMake 2.4.x does not automatically do so and we want | ||
33 | # compatibility with CMake 2.4.x. | ||
34 | if(HAVE_SYS_TYPES_H) | ||
35 | list(APPEND CMAKE_REQUIRED_DEFINITIONS -DHAVE_SYS_TYPES_H) | ||
36 | endif() | ||
37 | if(HAVE_STDINT_H) | ||
38 | list(APPEND CMAKE_REQUIRED_DEFINITIONS -DHAVE_STDINT_H) | ||
39 | endif() | ||
40 | if(HAVE_STDDEF_H) | ||
41 | list(APPEND CMAKE_REQUIRED_DEFINITIONS -DHAVE_STDDEF_H) | ||
42 | endif() | ||
43 | check_type_size(off64_t OFF64_T) | 28 | check_type_size(off64_t OFF64_T) |
44 | if(HAVE_OFF64_T) | 29 | if(HAVE_OFF64_T) |
45 | add_definitions(-D_LARGEFILE64_SOURCE=1) | 30 | add_definitions(-D_LARGEFILE64_SOURCE=1) |