aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 1 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 814df18..00fe464 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,26 +20,11 @@ include(CheckCSourceCompiles)
20include(GNUInstallDirs) 20include(GNUInstallDirs)
21enable_testing() 21enable_testing()
22 22
23check_include_file(sys/types.h HAVE_SYS_TYPES_H)
24check_include_file(stdint.h HAVE_STDINT_H)
25check_include_file(stddef.h HAVE_STDDEF_H)
26
27# 23#
28# Check to see if we have large file support 24# Check to see if we have large file support
29# 25#
30set(CMAKE_REQUIRED_DEFINITIONS -D_LARGEFILE64_SOURCE=1) 26set(CMAKE_REQUIRED_DEFINITIONS -D_LARGEFILE64_SOURCE=1)
31# We add these other definitions here because CheckTypeSize.cmake 27
32# in CMake 2.4.x does not automatically do so and we want
33# compatibility with CMake 2.4.x.
34if(HAVE_SYS_TYPES_H)
35 list(APPEND CMAKE_REQUIRED_DEFINITIONS -DHAVE_SYS_TYPES_H)
36endif()
37if(HAVE_STDINT_H)
38 list(APPEND CMAKE_REQUIRED_DEFINITIONS -DHAVE_STDINT_H)
39endif()
40if(HAVE_STDDEF_H)
41 list(APPEND CMAKE_REQUIRED_DEFINITIONS -DHAVE_STDDEF_H)
42endif()
43check_type_size(off64_t OFF64_T) 28check_type_size(off64_t OFF64_T)
44if(HAVE_OFF64_T) 29if(HAVE_OFF64_T)
45 add_definitions(-D_LARGEFILE64_SOURCE=1) 30 add_definitions(-D_LARGEFILE64_SOURCE=1)