aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ca10ab..fbe4f1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,8 @@ if(MSVC)
65 include_directories(${CMAKE_CURRENT_SOURCE_DIR}) 65 include_directories(${CMAKE_CURRENT_SOURCE_DIR})
66endif() 66endif()
67 67
68if(NOT CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_CURRENT_BINARY_DIR) 68option(RENAME_ZCONF "Rename the zconf when building out of source" ON)
69if(NOT CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_CURRENT_BINARY_DIR AND RENAME_ZCONF)
69 # If we're doing an out of source build and the user has a zconf.h 70 # If we're doing an out of source build and the user has a zconf.h
70 # in their source tree... 71 # in their source tree...
71 if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h) 72 if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h)